[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rc.local blocking



Is rc.local blocking no longer honered?

With RHL9 and below, we could run some scripts that would query the user 
for some information, using echo, and read and all that fun stuff.  
Even if the system was configured for GUI login (init 5) these scripts 
would run, and hold the system until the user input the information, at 
which point it would then flip out to the GUI login screen.  This 
worked great for our uses.  I cannot seem to duplicate this behavior 
with FC1.  I've tried disabling rhgb, both in grub and 
/etc/sysconfig/init, but it seems that no matter what, on the FIRST 
BOOT of an installed system, the text console out put stops right 
before the "Entering non-interactive run level 5" banner would show up.  
After the first boot, then I would get all the text, but by then my 
scripts have cleaned up after themselves and will no longer run.

Could somebody please help me figure out what is going on, and how to 
re-enable my scripts to block any further progression?

-- 
Jesse Keating RHCE MCSE (geek.j2solutions.net)
Fedora Legacy Team      (www.fedora.us/wiki/FedoraLegacy)
Mondo DevTeam           (www.mondorescue.org)
GPG Public Key          (geek.j2solutions.net/jkeating.j2solutions.pub)
 
Was I helpful?  Let others know:
 http://svcs.affero.net/rm.php?r=jkeating

Attachment: pgp00104.pgp
Description: signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]