[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora Core 1: X86-64 Failed compile package list



On Wed, 12 Nov 2003 Mohammed_Khan Dell com wrote:

> Folks,
> 
> I tried to cross-compile all the Fedora Core 1 (yarrow) SRPMS on an amd64
> machine running the i386 version of Fedora Core 1 (yarrow). 
> 

While certainly an interesting way to get to know the systems, cross 
compile environments are not always the cleanest.  All of these packages 
except for kernel (and some hardware pieces not needed for AMD64 systems) 
are already built and available for x86_64.  Kernel is an interesting 
beast, and currently being worked on.  Target for AMD64 packages is 
generally recognized as x86_64

> 
> 2. How would one go about fixing packages exhibiting the first issue
> (unknown target: amd64)? Is it a matter of:
> 	1. tweaking spec files
> 	2. tweaking make files
> 	3. tweaking source-code 
> 	4. combination of 1, 2, and 3? 
> 	5. ask/beg respective pacakage maintainers to fix? 
> 
> Thanks,
> 
> MFK 
> 

6. use --target=x86_64, or download existing builds if you would rather 
not eat up the CPU time.

If there are any other issued you run across, please feel free to ping me 
on them, and I will look into them.

Thanks,
Justin 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]