[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum tries to update gpgme03 with gpgme?



Following scenario:

  # rpm -e gpgme
  # rpm -qa 'gpgme*'
  gpgme03-0.3.15-0.fdr.2.1
  # rpm -q --whatrequires gpgme03
  sylpheed-gpg-0.9.7-0.fdr.1

  # yum -y install gpgme
  [...]
  Resolving dependencies
  .package sylpheed-gpg needs libgpgme.so.6 (not provided)
  package sylpheed-gpg needs gpgme03 >= 0:0.3.10 (not provided)

What did happen there? What does that error mean? Did Yum want to upgrade
gpgme03 with gpgme? The following makes me think that might be true:

  # rpm -q --provides gpgme03 | grep ^gpg
  gpgme = 0:0.3.15-0.fdr.2.1
  gpgme03 = 0:0.3.15-0.fdr.2.1

  # rpm -q --provides gpgme | grep ^gpg
  gpgme = 0:0.4.3-0.fdr.2

When I let it install both packages at once, it succeeds:

  # rpm -e gpgme03 --nodeps
  # yum -y install gpgme03 gpgme
  [...]
  Resolving dependencies
  Dependencies resolved
  I will do the following:
  [install: gpgme 0.4.3-0.fdr.2.i386]
  [install: gpgme03 0.3.15-0.fdr.2.1.i386]
  Running test transaction:
  Test transaction complete, Success!
  gpgme03 100 % done 1/2 
  gpgme 100 % done 2/2 
  Installed:  gpgme 0.4.3-0.fdr.2.i386 gpgme03 0.3.15-0.fdr.2.1.i386
  Transaction(s) Complete

-- 

Attachment: pgp00153.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]