[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VNC can't stats binary!



Paul Iadonisi wrote:
On Sun, 2003-11-23 at 05:19, Supphachoke Suntiwichaya wrote:
  
I download vnc-server-4.0-0.beta4.3.2.i386.rpm from update site.
It seem incorrect.

it norespond when

# file /usr/bin/Xvnc

??

I rebuilded but it can't ..
    

  I'm not sure what you mean by saying you couldn't rebuild it, but I
don't think that's relevant, anyhow.   The problem is likely with the
'file' command, not with Xvnc itself.  Wanna see something even
  

Sorry about my English.

weirder?  Try 'file /usr/bin/*' and you'll notice that it *doesn't* hang
and even returns 'executable,' for Xvnc.  Try any other file glob
(/usr/bin/X*, /usr/bin/[x-z]*' that matches Xvnc, and it does hang. 
Something very strange is going on here.  I even tried a for loop to
loop through all the binaries in /usr/bin, /bin, /usr/sbin, /sbin, and
/usr/X11R6/bin and Xvnc is the *only* binary that the file command hangs
on.

  

I make a new distribution  and used  update package (VNC) from update site, 
script udp-installroot can't run "file /usr/bin/Xvnc " it not responde .

but not happen when used old VNC ..

MrChoke

  Running it with strace doesn't reveal anything very informative, at
least not to me.

  Anybody else seeing this behavior?

  


-- 

Name : Supphachoke Suntiwichaya
Email : MrChoke opentle org
URL : http://jedi.links.nectec.or.th/mrchoke/
Distribution : LinuxTLE 5.0.95 (AowThai)
OS : Linux 2.4.22-6_1.2115.nptl_2tle #1 Sun Nov 23 12:51:40 ICT 2003 i686 GNU/Linux
Uptime :  17:40:00  up 2 days,  7:25,  1 user,  load average: 1.27, 0.55, 0.36

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]