[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: stateless wants pxelinux.0

The pxelinux.cfg file isn't part of stateless specifically, it's more of a general "here's some boot-time parameters" file. We've been using LTSP here for a while, and I know if you search that page or just google tftpboot +pxelinux you get a lot of docs referring to how the things are configured. I've seen man pages and such for it, but none are complete.

I'm trying to get the diskless version of staeless to run, because the LTSP local apps config is a nightmare, and I need the terminals' memory to handle the application being used. It has a terrible memory leak and I'd rather it drop one client than the whole server.

The present install of stateless is supposed to run a cron job every hour to manage all the pxe stuff, but it hasn't worked here yet. I'm starting this experiment over and running it off an nfs server to diskless clients, I'm going to try to install from the terminal directly to the NFS share and see if that works a little better, the "install it on a machine and then remove the hard drive" trick isn't getting it done, even with a clever-crafted pxelinux.cfg.

Jason Powers
Network Coordinator
Frontier Science

ps. my 'old' pxelinux.cfg/default file, which works for ltsp but not stateless. YMMV.

prompt=0 label linux kernel bzImage-2.4.26-ltsp-2 append init=/linuxrc rw root=/dev/ram0 initrd=initrd-2.4.26-ltsp-2.gz ipappend 1

Carlos Knowlton wrote:
Carlos Knowlton wrote:

Mark McLoughlin wrote:


On Mon, 2004-11-15 at 11:21 -0600, Carlos Knowlton wrote:

Okay, next question: (and remember, this is in the name of helping stateless (and clueless) newbies everywhere, so bear with me =)

I have stateless linux installed according with the tutorial <http://fedora.redhat.com/docs/stateless/index.html>, and I'm attempting to do a PXE boot on a diskless machine. The PC is able to get an IP address, and then tries to get "pxelinux.0", and fails with a PXE-T01 and PXE-E3B. "pxelinux.0 isn't even located in the /tftpboot directory anywhere. so I add it to where dhcpd.conf says it should be, in "/tftpboot/linux-install/pxelinux.0", what's next? how do I set up /tftpboot/linux-install/pxelinux.cfg/*"?

I think as long as you have tftp-server and syslinux installed it should be there. Although, now that I look, I'm not sure how it gets there - neither package owns it and pxelinux just installs it in /usr/lib.


Hmm, well, I just realized that when I ran stateless-clients to add a client, that somehow, it doesn't get added:
[root Server ~]# stateless-clients --configuration DemoSystem --add 00:11:11:4A:8A:21
[root Server ~]# stateless-clients -l
[root fsix-Server ~]#
could this be related?

Regards, Carlos

Okay, maybe it isn't related. Though, as someone mentioned earlier, the stateless-* utilities don't take long-form ("--") parameters. I got it working with "stateless-clients -c DemoSystem -a 00:11:11:4A:8A:21". Maybe the docs need to be updated (?).

Anyway, what is the format of the files in the pxelinux.cfg/* files supposed to be? what parameters need to be passed to the kernel, etc. and how is this stuff supposed to be generated?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]