[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Stateless Linux experience...

	No html mail thanks.

> On Mon, 2004-11-15 at 13:13 -0500, Mike Herrick wrote:

> 2) Even with the latest code, there is a typo on line 96 of 
> stateless-snapshooter.py ("--protosytem" should be "--protosystem").

	Should be fixed in CVS now.

> 3) I tried this on a machine that initially had 128MB of RAM.  When I 
> got to the "stateless-snapshooter -n -p DemoSystem" step, I ran out of
> memory: "device-mapper ioctl cmd 9 failed: Cannot allocate memory".  I
> added 128MB of RAM and still had the same problem, so I stopped some
> non-essential services (httpd, sendmail, etc.).  Then I was able to
> continue.

	Ouch, this is using LVM, right? What's taking up all the memory?

> 5) In the /etc/dhcpd.conf file, it refers to
> "linux-install/pxelinux.0" as the PXE bootable image, but when the PXE
> client connects this file is not found.  I 
> copied /usr/lib/syslinux/pxelinux.0 (from syslinux RPM)
> to /tftpboot/linux-install.

	I'm still not sure what's going on there. On my FC3 install pxelinux.0
is in /tftpboot/linux-install but no package owns it.

> 6) Because of the RAM problem above, I'm not sure that subsequent
> invocations of "stateless-snapshooter -n -p DemoSystem" actually
> worked as designed.  When I execute "stateless-snapshooter -l", I get:
> Protosystems:
>    DemoSystem
> But it doesn't say anything about snapshots.  This makes me nervous. 
> What should the output look like?

	Yeah, looks like there aren't any snapshots listed in LDAP.

	Are there snapshots in /srv/stateless/snapshots?

	Maybe use GQ (GUI LDAP client) to poke around in LDAP to see if any
record of the snapshots are being made?

> 7) When I run "python statelessGenPXEConfig.py" after adding the MAC
> addresses, I get "Unable to get NFS location of DemoSystem snapshot
> DemoSystem-1".  I'm not exactly sure where it's supposed to have
> picked up the NFS path definition from.  It appears to me from
> browsing some of the code that somewhere along the line I was supposed
> to have executed "stateless-servers", but I didn't see anything about
> that in the documentation.

	Right, it can't get snapshot information from LDAP. That's why it

> With these changes, I was able to get a machine to boot from the 
> snapshot, but there were many errors/warnings stemming from having a
> read-only root (and /var) filesystem on a diskless client.
> When I finally got the machine to boot, it wouldnât let me login!  I
> suspect some read-only root problem during the login process that
> prevented the login process from completing.

	Its possible the snapshot process never completed, and so that snapshot
wasn't properly prepared for readonly booting.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]