[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

prelink issues


I'm a bit worried because we've been seeing a number of issues recently
that seem to be related to prelink.  For example, we've been looking at
this bug today:


Debugging this locally, we found that the hal daemon segfaulted very
quickly on startup, dying inside libdbus.  However, it worked inside
valgrind.  Havoc yesterday mentioned that if he re-prelinked libdbus, it
worked.  We were able to confirm that.

A secondary issue is that we've occasionally seen shared libraries
suddenly not having the right SELinux contexts:

This has come up on earlier on this list too:

The hal/dbus issue appears to be reproducible on FC3+updates, but not
with stock FC3.  My guess is that letting prelink run on stock FC3 might
cause this too, I'm about to check that.

Has anyone else seen any odd issues with their packages that might be
related to prelink?  I wonder if there's a common thread here.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]