[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: i486 FC3

Enrico Scholz wrote :

> * replace the 'Requires: kernel >= 2.6' with 'Conflicts: kernel < 2.6'
>   (which would be more correctly also). The kernel package is not
>   required on minimal systems (e.g. VServers), it costs lot of diskspace
>   because of the stupid and broken packaging and its installation is
>   complicated.

I don't think there is an easy solution to this one! Putting a "Conflicts:
kernel < 2.6" would also be problematic, and I recall having seen that
somewhere (in FC2?), as I ran into the problem it creates :
When you upgrade a system using apt or yum from a 2.4 (or earlier) kernel
to FC w/ a 2.6 kernel, since the latest kernel is installed (and not
upgraded) and the older ones aren't removed, you bump into that conflict...
so either you go on a thin limb by removing all current < 2.6 kernels (with
--justdb preferably! still, ugly...), or you try to outsmart that conflict
by wanting to put a 2.6 kernel before upgrading the whole system... but end
up finding out that the chain of dependencies when trying to do that ends
up once more with that conflict :-(

Back to the missing dependency granularity in rpm that doesn't allow
something like "if we have a package providing 'kernel', then we want at
least one with its version >= 2.6.0". I'm not saying I want that, though,
but in this particular case, I see no "right" solution to the problem.

Then there is the creating a dummy package providing "kernel", for those
vservers it might just work.


Clean custom Red Hat Linux rpm packages : http://freshrpms.net/
Fedora Core release 3 (Heidelberg) - Linux kernel 2.6.9-1.681_FC3.r300
Load : 0.31 0.31 0.84

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]