[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Building FireFox 1.5 SRPMs on FC4...



Gilboa Davara wrote:

> Hello all,
> 
> Just wondering, I assume that FF 1.5 RPMs will be making their way into
> rawhide in the next couple of days.
> What are the chances of building their SRPMs on FC4? (x86-64 to be
> exact)
> Should I just give up and build the vanilla source package?
> 
> Gilboa
> 

Nope.  Just tried:
pmbuild --rebuild firefox-1.5-1.src.rpm
Installing firefox-1.5-1.src.rpm
error: Failed build dependencies:
        nspr-devel >= 4.6 is needed by firefox-1.5-1.x86_64
        cairo-devel >= 0.5 is needed by firefox-1.5-1.x86_64
[nbecker nbecker2 ~]$ rpm -q nspr-devel
package nspr-devel is not installed
[nbecker nbecker2 ~]$ sudo yum install nspr-devel cairo-devel
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: nspr-devel
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for cairo-devel to pack into transaction set.
cairo-devel-0.2.0-1.2.fc4 100% |=========================| 2.6 kB    00:00
---> Package cairo-devel.x86_64 0:0.2.0-1.2.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: cairo = 0.2.0-1.2.fc4.rf for package: cairo-devel
--> Processing Dependency: libpixman-devel for package: cairo-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libpixman-devel to pack into transaction set.
libpixman-devel-0.1.2-1.2 100% |=========================| 2.5 kB    00:00
---> Package libpixman-devel.x86_64 0:0.1.2-1.2.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: libpixman = 0.1.2-1.2.fc4.rf for package: libpixman-devel
--> Processing Dependency: cairo = 0.2.0-1.2.fc4.rf for package: cairo-devel
--> Finished Dependency Resolution
Error: Missing Dependency: cairo = 0.2.0-1.2.fc4.rf is needed by package cairo-devel
Error: Missing Dependency: libpixman = 0.1.2-1.2.fc4.rf is needed by package libpixman-devel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]