[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: kdebindings-3.5.0-0.1.fc4 pull in ruby



dennis ausil us (Dennis Gilmore) writes:

>> > Ruby itself didn't add 5m.  The package includes bindings for ruby,
>> > python, and perl, and all the other more generic things necessary to
>> > plug these pieces into KDE.  So while it can almost make sense to do a
>> > kdebindingsbase, then kdebindings-foo for each language, is it really
>> > worth the effort right now?
>
> Many moons ago Red Hat moved from having all the different apps in there own 
> binary rpms to having 1 rpm per tarball.

Not per application. But I would recommend a dependency based splitting.


>> I think such a split should be done (not for FC4 but for FC5). Currently,
>> people who need e.g. only ruby bindings are forced to install the huge
>> perl dependency.
> perl its used  by many more things

sed supports the '-i' switch for some time already, so a big justification
for perl does not exist anymore ;)


>> Unfortunatly, such packaging errors are seen often in Fedora
>> Core. E.g. people who want sendmail are forced to install MySQL and
>> PostgreSQL.
> client libs only  which i dont think is that bad

It is bad and does not make sense.


>> Or aspell -- it works perfectly without perl but a packaging bug
>> introduces this huge dependency. Unfortunatly, Fedora Core developers
>> are not sensitive to such bugs and have a "diskspace is cheap" thinking
>> without seeing consequences for security and maintainability of the
>> system.
> perl is required by many different packages  including X

I just took a look at some real-world productive servers. 12 of them DO
NOT need perl, 9 need perl. Here the details:

| $ LANG=C vrpm --all -- -e perl perl-Filter
| vrpm: operating on vserver backupc
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'backupc' with errorcode 2
| 
| vrpm: operating on vserver cheese
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'cheese' with errorcode 2
| 
| vrpm: operating on vserver db
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'db' with errorcode 2
| 
| vrpm: operating on vserver dhcp
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'dhcp' with errorcode 2

+4 for NO perl

| vrpm: operating on vserver dict
| error: Failed dependencies:
|         /usr/bin/perl is needed by (installed) dict-cgi-0.0.15-1.noarch
| vrpm failed on vserver 'dict' with errorcode 2

+1 for perl


| vrpm: operating on vserver kerberos
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'kerberos' with errorcode 2

+1 for NO perl


| vrpm: operating on vserver ldap
| error: Failed dependencies:
|         perl is needed by (installed) openssl-perl-0.9.7f-7.10.i386
|         /usr/bin/perl is needed by (installed) openssl-perl-0.9.7f-7.10.i386
|         /usr/bin/perl is needed by (installed) openldap-servers-2.2.29-1.FC4.i386
| vrpm failed on vserver 'ldap' with errorcode 2
| 
| vrpm: operating on vserver ldap-master
| error: Failed dependencies:
|         perl is needed by (installed) openssl-perl-0.9.7f-7.10.i386
|         /usr/bin/perl is needed by (installed) openssl-perl-0.9.7f-7.10.i386
|         /usr/bin/perl is needed by (installed) openldap-servers-2.2.29-1.FC4.i386
| vrpm failed on vserver 'ldap-master' with errorcode 2

openssl-perl is required by my applications

perl-dep in openldap-servers is a packaging bug. Migrate scripts should
be in an own package.

+2 for perl


| vrpm: operating on vserver logalyzer
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'logalyzer' with errorcode 2

neutral, not configured yet


| vrpm: operating on vserver mail-filter
| error: Failed dependencies:
|         libperl.so is needed by (installed) mimedefang-2.52-2.i386
|         ...
| 
| vrpm: operating on vserver mail-local
| error: Failed dependencies:
|         ...
|         perl >= 0:5.006_001 is needed by (installed) spamassassin-3.0.4-2.fc4.i386
|         ...
| 
| vrpm: operating on vserver mail-www
| error: Failed dependencies:
|         perl(Carp) is needed by (installed)
|         perl-Cyrus-2.2.12-6.fc4.sigma.i386
| 
| vrpm: operating on vserver mailbox
| error: Failed dependencies:
|         perl >= 1:5 is needed by (installed)  cyrus-imapd-2.2.12-6.fc4.sigma.i386
|         ...
| 
| vrpm: operating on vserver news
| error: Failed dependencies:
|         libperl.so is needed by (installed) inn-2.4.2-3.i386

ok, it is really needed here

+5 for perl


| vrpm: operating on vserver ns
| error: package perl is not installed
| error: package perl-Filter is not installed
| vrpm failed on vserver 'ns' with errorcode 2

+1 for NO perl...


| vrpm: operating on vserver svn
| error: Failed dependencies:
|         perl >= 1:5.0 is needed by (installed) subversion-1.2.3-2.1.i386
|         ...

Packaging bug; %doc files must not add new dependencies

+1 for NO perl


| vrpm: operating on vserver syslog
| error: Failed dependencies:
|         perl(POSIX) is needed by (installed) stunnel-4.08-2.i386
|         /usr/bin/perl is needed by (installed) stunnel-4.08-2.i386

not really needed; the 'stunnel3' backward-compatibility program should
be in a separate package or packaged as %doc

So, +1 for NO perl


| vrpm: operating on vserver twiki
| error: Failed dependencies:
|         perl >= 0:5.005 is needed by (installed) twiki-0.0.20040904-0.i386

+1 for perl


| vrpm: operating on vserver vpn
| error: Failed dependencies:
|         /usr/bin/perl is needed by (installed) openvpn-2.0.5-1.fc4.i386
| vrpm failed on vserver 'vpn' with errorcode 2

packaging bug; %doc must not add new deps

+1 for NO perl


| vrpm: operating on vserver www-cache
| error: Failed dependencies:
|         perl >= 0:5.003 is needed by (installed) squid-2.5.STABLE11-3.FC4.i386

packaging bug; %doc must not add new deps
smbauth scripts should be in an own package

+1 for NO perl


| vrpm: operating on vserver www.XXX.de
| error: Failed dependencies:
|         /usr/bin/perl is needed by (installed) aspell-0.50.5-6.i386
| vrpm failed on vserver 'www.XXX.de' with errorcode 2
| 
| vrpm: operating on vserver www.YYYYYYYYYY.de
| error: Failed dependencies:
|         /usr/bin/perl is needed by (installed) aspell-0.50.5-6.i386
| vrpm failed on vserver 'www.YYYYYYYYYY.de' with errorcode 2

packaging bug; unneeded program (aspell-import) introduces perl dep

+2 for NO perl




Enrico


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]