[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Enable sqlite database backend in QT



Rex Dieter wrote:
> Bernardo Innocenti wrote:
> 
>>> +%if %{buildsqlite}
>>> +BuildRequires: sqlite2-devel
>>> +%endif
>>> +
>>> BuildRequires: fontconfig-devel >= 2.0
> 
>> This chunk isn't actually needed because Qt builds
>> against its in-tree copy of sqlite.
> 
> AFAICT, from looking at the code (correct me if I'm wrong)... the
> in-tree copy is used only if a system copy isn't found.

That's right.

btw, sqlite2-devel is a Extras package.  Are Core packages
allowed to depend on Extras (if only through BuildRequire)?

Alternatively, does the Fedora build harness support to
put just the qt-sqlite package in Extras and keep the
remaining packages in Core?

Qt4 uses sqlite3, so this dependency problem will go away
some day.

-- 
  // Bernardo Innocenti - Develer S.r.l., R&D dept.
\X/  http://www.develer.com/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]