[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't upgrade to Rawhide



Rahul Sundaram wrote:

>> http://labix.org/smart/faq#head-23a262be2555f1b386b7f8ca158010a49dd07ad3

I know for that, but SmartPM just hanged when I was tryed to upgrade the
system into Rawhide. Here's my channel:

----------------------------------------------------------------------
# Name: Development
# URL: http://ayo.freshrpms.net/
[fc-dev]
name = Development
baseurl = http://ayo.freshrpms.net/fedora/linux/development/i386/core/
type = rpm-md
----------------------------------------------------------------------

> Smartpm can use yum metadata but its not just a frontend and its 
> dependency resolves works very differently. Most notably it attempts to 
> downgrade packages on occasions to resolve dependencies automatically 
> which isnt what RPM is optimally designed or tested to do.

I didn't know for that, thanks.

> Whether its 
> desirable or if its a improvement is debatable. Yum obviously is getting 
> better integrated with Anaconda, system-config-packages and so on.

I read that Yum is the new dependency resolver for Anaconda, and
system-config-packages as well. I like Yum better because it provides
some features I've never seen on Apt or Smart (package repackaging and
installing packages locally - 'yum localinstall'). But it is slower than
Apt and Smart, for now :-/

> Of 
> course now that Smartpm is under review for Fedora Extras repository, 
> you have the choice easily.

Well, I'm not some SmartPM fan or something, I was just playing with it.
Seems nice tool. Or it isn't as it looks like?

Cheers!

-- 
Igor Jagec


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]