kudzu network weirdness

Michael A. Peters mpeters at mac.com
Tue Feb 15 18:14:46 UTC 2005

Changing my network, or at least - preparing to.

Formerly I had 3 ethernet devices - as seen by Fedora:

eth0: onboard 3Com nic (a7n8x deluxe)
eth1: pci card, linksys generic
eth2: onboard forcedepth nvidia nic (did not use)

eth1 is what was attached to my DSL modem (since it was the only nic  
Win XP knew what to do with after a bare install w/o board driver disc)

eth0 goes to a hub which has my iMac and a LaserJet 4 attached

My plan was remove the pci ethernet card (eth0) and until I have the  
wireless router set up, use the forcedepth nic for my PPPoE.

I moved the ethernet cable and used the network control panel to change  
the PPPoE to eth2. Restarted network - it was good, I could ping yahoo.

I removed the pci card that was eth1 and installed an Atheros wireless  
card (AT&T P&S 6500G). I have the madwifi drivers installed.

kudzu deleted the pci card, I told to ignore the wireless card, as from  
fedora user list archive, that is what I'm suppose to do. Kudzu did  
correctly enter the wireless card into /etc/sysconfig/hwconf

I'm not sure why, but for the life of me, I could not get it to use the  
forcedepth card for the dsl - even though it had worked when I had  
switched it before doing the hardware change.

Looked in the /etc/modprobe.conf - the reference to forcedepth as eth2  
was still there, and an additional reference to forcedepth as eth1 was  
also there - at the end of the file, as if kudzu had just put it there.

Looked in /etc/sysconfig/hwconf - and the foredepth card was only there  
as eth2. There was no eth1 (and shouldn't have been).

Manually altered /etc/sysconfig/hwconf to make the forcedepth card be  
eth1 there, deleted /etc/sysconfig/network-scripts/ifcfg-eth2 - and  
rebooted, changed the PPPoE device to use eth1, everything worked fine  

I don't know if this is a kudzu bug or a quirk or what, but it seems  
that when the Linksys card that was eth1 was removed by kudzu, that  
since there now was no eth1 anymore, that gave a problem and eth2 could  
not be used to bring up PPPoE - so eth2 *should* have been migrated to  
eth1 in both /etc/sysconfig/hwconf and /etc/sysconfig/network-scripts -  
which is effectively what I manually did.

Unfortunately it would a real PITA to try and duplicate this.

Michael A. Peters

More information about the fedora-devel-list mailing list