rpm -i bla.i?86.rpm problems

Erwin Rol mailinglists at erwinrol.com
Fri Feb 18 22:51:21 UTC 2005

Hey all,

I tried rebuilding rpmdb-fedora from the source rpm and noticed a
problem (which could certainly be because i did something wrong :-). For
all rpm's in my directory of rpms (the ones i want in the db) that have
more than one arch (for example glibc , i386 and glibc i686) i get an
error like:

error: error reading from file glibc-2.3.4-10.i686.rpm

Now i changed the spec file to only include i386 and noarch rpms and it
works fine. 

I tried with the following quick test to reproduce the effect:

[root at drake RPMS]# rpm -i --justdb --force glibc-2.3.4-10.i386.rpm glibc-2.3.4-10.i686.rpm
error: error reading from file glibc-2.3.4-10.i686.rpm

[root at drake RPMS]# rpm -i --justdb --force glibc-2.3.4-10.i686.rpm glibc-2.3.4-10.i386.rpm
error: error reading from file glibc-2.3.4-10.i386.rpm

As you can see it complains about the second rpm it finds that just
differs in arch. The files are all 100% correct, since i can install
them one by one, just not in one go.

This is on a chrooted minimal install with the latests (rsync'ed a few
hours ago) rpms from the development directory. 

Is this expected behavior ?

- Erwin

More information about the fedora-devel-list mailing list