Lots of erros in Yum doing update (was Re: rawhide report: 20050222 changes)

Colin Walters walters at redhat.com
Thu Feb 24 16:18:16 UTC 2005

On Thu, 2005-02-24 at 11:44 +1100, Rodd Clarkson wrote:

>Yeah, turning of selinux fixed it (although I'm still not sure how to
>run the post scripts for all the packages that fails (hint hint))

If you have to disable it for some reason, please please post the "avc:
denied" messages in /var/log/messages to fedora-selinux-list (or file a
Bugzilla) to give us a chance to figure out what the problem is.

Often too you can just disable protection for one service or just 
temporarily "setenforce 0" without disabling it permanently.

Also let me second Seth's statement wrt rawhide and babies :)

>I've actually been running without selinux for a couple of weeks now
>because my nose is to the grind stone and I need to use apache and mysql
>and for some reason I need to configure this to work (haven't had time
>to do so).

It seems like a bad idea to be depending on stuff to work in rawhide
when your nose is to the grind stone...

>With the update I turned selinux on by accident and it caused all this
>stuff.  Turning if off I was able to run yum update and get the kernel
>and openssh-server to install.

Hopefully we can track down the problem once we get the avc messages.

More information about the fedora-devel-list mailing list