[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Linux-ATM-General] OAM not support [SOLVED]



Il giorno lun, 24/07/2006 alle 17.05 +0200, Sk3 Sk3 ha scritto: 
> Dario Lesca escribió:

> Make this changes on usbatm.c likes this:
> http://zyxel630-11.cvs.sourceforge.net/zyxel630-11/amedyn2/module/usbatm.c?r1=1.7&r2=1.8
> 
> The patch are from Roman Kagan
> 
> http://sourceforge.net/mailarchive/message.php?msg_id=11987440

Ok. now my ADSL Telecom(italy) work great with this patch !

I have use the last version of cxacru.c and usbatm.c modules, take from
last FC4 official kernel, I have arranged the zyxel patch and I have
produced this structure (see attach):

> usbatm-oam-support/
> usbatm-oam-support/usbatm.c
> usbatm-oam-support/usbatm.h
> usbatm-oam-support/Makefile
> usbatm-oam-support/cxacru.c
> usbatm-oam-support/usbatm.c.orig
> usbatm-oam-support/usbatm.h.orig
> usbatm-oam-support/usbatm-oam-support.patch

The OAM feature it is necessary with some ADSL therefore would be useful
that this patch comes introduced in ATM support of the kernel... or not?
How I can make this demand?
Where I must send the patch (of Roman Kagan) in order to demand to
insert it in the kernel?

Or I must always patch the standard kernel modules?
To this purpose, there is a method for automate the rebuild only the
driver after a standard update of the kernel (yum update kernel) without
patch and rebuild the kernel-src rpm?

Many thanks, and sorry, I am not a driver developer :-(

-- 
Dario Lesca <d lesca solinos it>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]