[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HELP NEEDED Re: updating Xchat and friends



Warren Togami wrote:
Joseph E. Sacco, Ph.D. wrote:
The current version of Xchat is 2.6.0-6.  Version 2.6.6  was released on
17July. A release of 2.6.7 for Linux is imminent.

The later versions support spell checking, which is a good thing. There
are configuration options that provide choices for spell checking
mechanisms.  By default, configure will elect to link in libsexy if
found. libsexy will use enchant by default.


I built 2.6.6 using the src rpm from 2.6.0-6.  I used a simplistic
approach:
* downloaded the 2.6.6 tar ball from xchat.org
* edited the 2.6.0 spec file
- changed the version numbers
- stripped out all of the patches [:-)]

Builds and runs fine.


We'd certainly like to have the latest versions of this in FC. However caillon is currently too busy to maintain this package. We would be happy for help in updating the package, but simply stripping out the patches is not acceptable.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201116
If somebody would like to examine each patch and determine whether they are still needed or not, please attach updated spec and patches here, and they can be included after FC6test2.

I am willing to do it. I have been doing it for myself for a while.
There is also a newer version of enchant available:

        enchant: 1.2.6

enchant is in Extras, and we are already well past FC6 feature freeze, so we cannot include it in Core for xchat to use. We may consider this for FC7.
It can also use gtkspell. Which is in core. Another option would be to drop xchat from Core if caillon is too busy to maintain it. I am sure that would upset some people, but seems practical under the circumstances.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]