[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dependencies a little excessive?



On Wed, 2006-08-09 at 18:11 +0200, Matthias Saou wrote:
> Rahul wrote :
> 
> > Naoki wrote:
> > > So I nonchalantly typed this and walked away from my rawhide box.. 
> > > 
> > > "yum -y install libgnome-devel gcc-c++"
> > > 
> > 
> > libgnome-devel pulls in a lot of deps. Thats normal.
> 
> Yeah, but he probably wanted to do :
> 
> yum -y install libgnome-devel.x86_64 gcc-c++.x86_64
> 
> I don't like the yum "feature" of installing all available archs of a
> same package when it's explicitly requested either...
> 

If you have a patch that nicely deals with:

yum install libgnome\*

and guesses if the user meant: install libgnome*.x86_64 or
                               install libgnome.*(all archs)

send it to me, I'm amenable to that sort of thing.

-sv



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]