[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: some closure on the xorg updates issue



Rahul wrote:
Jeroen van Meeuwen wrote:
It's too bad yum isn't able to also remove packages from the updates-to-be-applied list once it appears dependencies concerning such a package are unresolvable.

Wouldn't you agree such feature in yum may solve the issue at hand here?


No. It would be a bad feature to ignore unresolvable updates in general since they might very well be critical security features. So the users need to be aware of conflicts and make the choices manually if they want to ignore any updates. Exposing a method to do so in tools like Pup would be a good idea however and there are already feature requests to do the same.

Rahul

Personally, I'd rather have yum disregard the package that causes the dependency error and update the rest (which in this particular case may as well contain hundreds of critical updates) then the update process to fail. Disregarding the package when updating however is not the same as the amount of noise yum wants to make about the disregarded package...

Kind regards,

-kanarip

--
Jeroen van Meeuwen, LPIC-1, MCP
http://www.kanarip.com/
C6B0 7FB4 43E6 CDDA D258  F70B 28DE 9FDA 9342 BF08


Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]