[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [DEP-BLOAT] 'mkinitrd' ships 'nash' and requires lot of low-level stuff



On Mon, 2006-08-21 at 11:40 +0200, Enrico Scholz wrote:
> Hello,
> 
> the 'mkinitrd' package contains the '/sbin/nash' program and has
> dependencies on lot of low-level stuff (e.g. device-mapper, dmraid,
> lvm2).
> 
> 'nash' and this deps are used for different purposes:
> 
> * 'nash' is called by 'initscripts' during every boot

it is ??
I didn't realize it was used outside of the initrd (and can't imagine
any use for it either)

> * the low-level stuff is used during kernel upgrade only

actually they are used at each boot as well, just from the initrd
itself.


> Therefore, they should be packaged separately.

why? Both are going to be mandatory anyway.... mkinitrd is when you want
to be able to upgrade kernels, or build your own or ... 
That's a core capability in terms of being able to apply security
updates. Being able to do security updates is not optional.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]