[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm db problem



On Thu, 2006-08-31 at 10:08 +0200, Erwin Rol wrote:
> On Thu, 2006-08-31 at 09:53 +0200, Patrice Dumas wrote:
> > On Thu, Aug 31, 2006 at 09:29:42AM +0200, Erwin Rol wrote:
> > > This morning i tried to do a yum update and got an error, when trying a
> > > rpm -qa i got the following error;
> > > 
> > > [root xpc erwin]# rpm -qa
> > > rpmdb: /var/lib/rpm/Packages: Invalid hash meta page 0
> > > error: cannot open Packages index using db3 - Invalid argument (22)
> > > error: cannot open Packages database in /var/lib/rpm
> > > 
> > > I have no idea how this happened, have others seen this problem
> > 
> > I also have ahd issues with rpm database corruption, but I don't know
> > what caused it nor how to reproduce it. sometimes there is a segfault 
> > when running yum, which is certainly in the rpmlib, and I guess it is 
> > what screews things, and also sometimes rpm never finish.
> 
> I never seen RPM hang on this machine, but i did see it happen on my
> dual core machine. 
> 
> > > recently? And more important how can it be fixed?
> > 
> > What I do is
> > 
> > rm -f /var/lib/rpm/__db*
> > db_verify /var/lib/rpm/Packages
> > rpm --rebuilddb
> 
> Yeah i did this minus the db_verify part.
> 
> One silly question, didn't rpm start using sqlite?  But the databases
> are still BDB?

rpm defaults to bdb use. It _can_ use sqlite. 

-sv



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]