[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: compiz problem - No window managment.



Zoltan Boszormenyi írta:
Naoki írta:
On Tue, 2006-08-29 at 14:06 -0400, Kristian Høgsberg wrote:
Adam Jackson wrote:
Naoki wrote:
As I reported back on the 24th compiz was failing to perform any window management, meaning all windows were on one workspace and had no borders
and could not be altered.   Matthias Saou correctly noted that this
would happen if DRI was not loaded which was exactly my problem. With the latest rawhide though the problem is back but there seems to be no
DRI problem in this instance..
It happens when you're not running gnome-window-decorator, or whatever it's called.
It can also happen if the compiz gconf database got screwed, which can happen if you upgraded from something earlier than 0.0.13-0.12.20060721git. In that case, uninstall and then reinstall compiz.

Other than that, as Adam mentions, compiz relies on an external helper program, gnome-window-decorator, to draw the window decorations. The recommended way to start compiz is to go to the System->Preferences->More Preferences->Desktop Effects and click the big button there. This will start compiz the right way and set it as your default windows manager. If that still doesn't work for, please let us know.

Howdy, indeed the only way I enable it is through the preferences
window. Your trick of remove/re-install has solved the issue for me
though thanks!

Unfortunately it doesn't work for me, only half way.
I have a dualseat machine with two separate
X servers/keyboards and mice.
Screen :0 is a Radeon 7000VE PCI,
screen :1 is a Radeon 9200SE AGP.
I use uptodate RawHide.

I tried to enable desktop effects on :1 and
although gnome-window-decorator is started
according to "ps", I get no window decoration.
Then I disabled it and enabled on :0 and the
acceleration works quite well.

But here's a bug: the screen is 1280x1024 and
the background picture is cut so only the left side
1024x1024 area is correct, the remaining stripe
on the right side gets black.

Starting xwininfo and clicking the root window
shows that its size became 1024x1024 somehow.
Disabling desktop effects the root window becomes
1280x1024 again.

Dragging wobbly windows all around works
on the whole screen, so 3D is definitely working.
The window dragging leaves traces on the
otherwise black right side.

Well, the remove/reinstall wasn't enough,
I had to do these:

yum remove compiz
# for both users/screens:
gconftool-2 --recursive-unset /apps/compiz
yum install compiz

to get it working on both screens.

But the 1024x1024 limit is still there on the
Radeon 7000VE (r100), the Radeon 9200SE (rv280)
works beautifully.

Best regards,
Zoltán Böszörményi


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]