[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Please disable the SELinux execstack/relro checks before FC5 final

This NVidia driver issue seems to be cropping up a lot on the forums. Is there a fix for it other than setting permissive globally?

Has anybody ever tried to simply reset the flag?  Use

execstack -c /usr/lib*/libGL.so
This thread is totally confusing me....
I haven't been following exactly what's going on with this problem, but:
- /usr/lib*/libGL.so.1 is the Mesa GL library
- /usr/lib*/nvidia/libGL.so.1 is the Nvidia GL library, when properly installed via livna

On my computer both are marked GNU_STACK RWE, which seems relevant to this problem (correct me if that's not true), so I'm not sure why Nvidia is being blamed, and Mesa is not. This is x86_64.

- I get denials attempting to execute /dev/zero, exectstack, and execmem for glxgears with the Nvidia driver. - I tried testing with the nv driver, but it crashed after I restarted X a few times, so I think selinux is not the primary problem when it comes to this driver. I'm running back to the "stable" nvidia driver [ even though it crashes on suspend ] :)

Will do more testing, but the point is that it's not clear which libGL library is causing the problem from this thread.
[jim cornette-lt ~]$ locate libGL.so.1
Doesn't this indicate the Mesa libGL library, and not the Nvidia or ATI one?

I take it that there are many more instances around.

Yes, I would expect to see problems with binaries that link to libGL...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]