removing kernel-devel rpms

Bart Vanbrabant bart.vanbrabant at
Sat Jan 14 13:13:27 UTC 2006

Mike Chambers wrote:
> On Sat, 2006-01-14 at 12:26 +0100, Bart Vanbrabant wrote:
>> A few weeks back I installed xen and the kernels needed to run it. These
>> kernels where to old to run the new udev and stuff like that so I
>> removed them. I managed to remove them all except
>> kernel-xen-hypervisor-devel. Now when I try to remove this package or
>> any other kernel-devel package rpm starts to use 100% cpu and eating up
>> all my memory (no swapping) and that's it. I have to kill it with kill -9.
>> I also tried removing it with yum but this gives the same result.
> You try removing the kernel-devel packages by version (one by one)
> instead of the whole thing?
> yum remove kernel-devel-1.2.3
Yeah, that the way I do it. Mostly I do it with rpm -e so I need to
specify the version to remove. The debug output of rpm is when I
specified a package.

Bart Vanbrabant <bart.vanbrabant at>
PGP fingerprint: 093C BB84 17F6 3AA6 6D5E  FC4F 84E1 FED1 E426 64D1

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the fedora-devel-list mailing list