rawhide report: 20060124 changes

David Woodhouse dwmw2 at infradead.org
Tue Jan 24 23:13:05 UTC 2006

On Tue, 2006-01-24 at 10:11 -0500, Neal Becker wrote:
> Cool, but not ready for primetime.  No encryption support.

I use it with WEP. Since the last update a week or two ago, it's
_supposed_ to also work with WPA although I haven't tried. I might set
up a spare AP when I get home so that I can test that.

I'd agree that it's not necessarily ready for primetime yet, but not
because of lack of encryption. The main problem with it (for me) is that
it doesn't automatically reduce the rate until it starts working -- if
it can't operate at 54M then it'll just fail, unless you explicitly
reduce the rate ('iwconfig eth1 rate 11M'). 

As long as I do that, it works quite nicely with NetworkManager,
Suspend/resume works fine too. I'm using it right now, in fact,
connected to the busy wireless network at linux.conf.au.

It's also a little sensitive to the order of initialisation -- you have
to bring the link up ('ip link set eth1 up') before setting essid and
keys, etc. So I believe that our standard initscripts don't work with it
-- you have to bring the link up first manually.

> I need to use ndiswrapper still.  How do I prevent activation of bcm43xx?  I
> tried removing it from modprobe.conf, but it is still getting loaded, and
> then ndiswrapper won't work.

Try just deleting the bcm43xx.ko file -- I'm not sure
if /etc/hotplug/blacklist is still honoured. 

I did consider removing the 'MODULE_DEVICE_TABLE' line from the driver,
so it doesn't automatically get loaded when a device with the
appropriate PCI ID is found.... would that be useful?

To use the bcm43xx driver, you'll need to fetch the fwcutter tool from
ftp://ftp.berlios.de/pub/bcm43xx/snapshots/fwcutter/ and run it on your
existing Windows or MacOS driver to extract the firmware, then move it
into /lib/firmware. See the README therein for details.


More information about the fedora-devel-list mailing list