[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libm



On Thu, Apr 27, 2006 at 06:42:47PM +0200, Rudi Chiarito wrote:
> Hello,
> I have a couple of questions that maybe someone can help with. Exhibit A
> is an x86_64 FC3 system:
> 
> # objdump -p /usr/lib64/libfftw.so | grep -A20 Version
> Version References:
>   required from libm.so.6:
>     0x09691a75 0x00 03 GLIBC_2.2.5
[...]
> # objdump -p /usr/lib64/libfftw.so | grep -A20 Version
> Version References:
[...]

Almost three months later, I have come across Exhibit C, fftw2 on a
i386 FC5 system (all three exhibits are official Extras packages):

# objdump -p /usr/lib/libfftw.so | grep -A20 Version
Version References:
[...]
  required from libm.so.6:
    0x0d696910 0x00 02 GLIBC_2.0

Is there a reason why under 32bit FC5 and 64bit FC3 the library
references libm, while it doesn't under 64bit FC5? It doesn't look like
the most predictable behaviour to me. Which of the two is considered
more proper?

-- 
Rudi


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]