[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum can't find dependencies



Hey all,

Somehow yum doesn't seem to be able to find dependencies. As you can see
below when i do "yum update gaim" it complains that it needs things and
can't find them, but when I add those dependencies on the command line
it works.

- Erwin


[root xpc erwin]# yum update gaim
Setting up Update Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 1.1 kB    00:00
freshrpms                 100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gaim.x86_64 2:2.0.0-0.6.beta3.1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: gaim
--> Processing Dependency: gaim = 2:2.0.0-0.6.beta3.fc6 for package: gaim-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc.x86_64 0:2.4.90-13 set to be updated
---> Package gaim-devel.x86_64 2:2.0.0-0.6.beta3.1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-common = 2.4.90-13 for package: glibc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-common.x86_64 0:2.4.90-13 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-common = 2.4.90-12 for package: glibc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc.i686 0:2.4.90-13 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-headers
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-utils
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-headers.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-utils.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-devel.x86_64 0:2.4.90-13 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.4.90-12 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.4.90-12 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package glibc-devel needs glibc = 2.4.90-12, this is not available.
Error: Package glibc-devel needs glibc-headers = 2.4.90-12, this is not available.

[root xpc erwin]# yum update gaim glibc glibc-headers
Setting up Update Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 1.1 kB    00:00
freshrpms                 100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package glibc.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-headers.x86_64 0:2.4.90-13 set to be updated
---> Package glibc.i686 0:2.4.90-13 set to be updated
---> Package gaim.x86_64 2:2.0.0-0.6.beta3.1.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: gaim = 2:2.0.0-0.6.beta3.fc6 for package: gaim-devel
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc-common = 2.4.90-13 for package: glibc
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-utils
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gaim-devel.x86_64 2:2.0.0-0.6.beta3.1.fc6 set to be updated
---> Package glibc-common.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-utils.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-devel.x86_64 0:2.4.90-13 set to be updated
--> Running transaction check
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.4.90-12 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.4.90-12 for package: glibc-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package glibc-devel needs glibc = 2.4.90-12, this is not available.
Error: Package glibc-devel needs glibc-headers = 2.4.90-12, this is not available.

[root xpc erwin]# yum update gaim glibc glibc-headers glibc-devel
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package glibc.i686 0:2.4.90-13 set to be updated
---> Package glibc.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-headers.x86_64 0:2.4.90-13 set to be updated
---> Package gaim.x86_64 2:2.0.0-0.6.beta3.1.fc6 set to be updated
---> Package glibc-devel.i386 0:2.4.90-13 set to be updated
---> Package glibc-devel.x86_64 0:2.4.90-13 set to be updated
--> Running transaction check
--> Processing Dependency: gaim = 2:2.0.0-0.6.beta3.fc6 for package: gaim-devel
--> Processing Dependency: glibc-common = 2.4.90-13 for package: glibc
--> Processing Dependency: glibc = 2.4.90-12 for package: glibc-utils
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gaim-devel.x86_64 2:2.0.0-0.6.beta3.1.fc6 set to be updated
---> Package glibc-common.x86_64 0:2.4.90-13 set to be updated
---> Package glibc-utils.x86_64 0:2.4.90-13 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 gaim                    x86_64     2:2.0.0-0.6.beta3.1.fc6  development       5.6 M
 glibc                   i686       2.4.90-13        development       5.0 M
 glibc                   x86_64     2.4.90-13        development       4.6 M
 glibc-devel             i386       2.4.90-13        development       1.9 M
 glibc-devel             x86_64     2.4.90-13        development       2.4 M
 glibc-headers           x86_64     2.4.90-13        development       587 k
Updating for dependencies:
 gaim-devel              x86_64     2:2.0.0-0.6.beta3.1.fc6  development       152 k
 glibc-common            x86_64     2.4.90-13        development        16 M
 glibc-utils             x86_64     2.4.90-13        development       112 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       9 Package(s)
Remove       0 Package(s)

Total download size: 36 M
Is this ok [y/N]:



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]