[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20060720 changes



Erwin Rol wrote:
On Thu, 2006-07-20 at 05:36 -0400, buildsys redhat com wrote:

Broken deps for x86_64
----------------------------------------------------------
	antlr-jedit - 2.7.6-3jpp_1fc.x86_64 requires jedit >= 0:4.1
	f-spot - 0.1.11-3.1.x86_64 requires mono(dbus-sharp) = 0:0.60.0.0
	gnome-python2-nautilus-cd-burner - 2.15.4-1.x86_64 requires libdbus-1.so.2()(64bit)
	gnome-screensaver - 2.15.4-4.x86_64 requires dbus-glib >= 0:0.90
	system-config-soundcard - 2.0.0-2.noarch requires pycairo > 0:1.2.0
	tomboy - 0.3.5-7.x86_64 requires mono(dbus-sharp) = 0:0.60.0.0

Since there are still packages that depend on the old dbus it is still
not possible to do a simple "yum update". Is there a better way to
update the packages that can be updated without hand picking them from
the list ?

Couldn't yum just update everything that is update-able and give a
warning at the end that some packages could not be updated due to what
ever reason. A bit like creating a list of all available updates and
than doing a "yum update <package name>" for each update available and
warn about the ones that can't be updated due to errors? Or is there
already some magic commandline option that can do this ?
I'm a big fan of that idea! I'm trying to update now and my exclude list has grown to King Kong proportions because of this :

Error: Missing Dependency: dbus >= 0.90 is needed by package gnome-mount
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-vfs2 Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package dhcdbd Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package NetworkManager
Error: Missing Dependency: dbus >= 0.90 is needed by package hal-cups-utils
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-mount Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package avahi
Error: Missing Dependency: libdbus-1.so.3 is needed by package dbus-glib
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package bind
Error: Missing Dependency: dbus >= 0.90 is needed by package NetworkManager-glib Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-session
Error: Missing Dependency: dbus = 0.90-6 is needed by package dbus-x11
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gaim
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package cups
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package totem Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package libnotify Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package dbus-glib Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package evince Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package dbus-python Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package hal-cups-utils
Error: Missing Dependency: dbus >= 0.90 is needed by package cups
Error: Missing Dependency: dbus >= 0.90 is needed by package gnome-volume-manager Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package krb5-auth-dialog Error: Missing Dependency: dbus >= 0.90 is needed by package desktop-printing Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package control-center Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package NetworkManager-glib Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-volume-manager
Error: Missing Dependency: dbus >= 0.90 is needed by package hal
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package notification-daemon Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-media Error: Missing Dependency: dbus >= 0.90 is needed by package NetworkManager-gnome Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gstreamer-plugins-good Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package libgnomecups Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package NetworkManager-gnome Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package bluez-pin Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package rhythmbox Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-power-manager Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package nautilus-cd-burner Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package desktop-printing Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-panel
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package hal
Error: Missing Dependency: dbus >= 0.90 is needed by package NetworkManager
Error: Missing Dependency: libdbus-1.so.3()(64bit) is needed by package gnome-applets

Excluding each of those isn't worth it, I'll wait for next build :)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]