[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlint and Obsoletes: loops



> I'd like to see the default Fedora rpmlint configuration error on
> "Obsoletes:" without a version, and warn on "Provides:" without one
> either, if that's not already the case.

This also helps for other surprises: If the Provides: don't have a version
number, then any versions specified e.g. on the Requires:/Conflicts:/Obsoletes:
part are just ignored...

Usually this happens only with "Requires: blah > 0.9" and newest packages
should then be ok, but still we then easily ignore the specified versions.

regards,

Florian La Roche


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]