[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Pull off AIGLX repoistory?



Mike A. Harris wrote:
Michael Knepher wrote:
On Wed, 2006-07-26 at 00:18 +0200, Dennis Jacobfeuerborn wrote:
If FC5 hadn't supported the proprietary drivers in the first place
then I wouldn't see a problem here since the users had a choice of upgrading to/installing FC5 with that fact in mind

I think you have that backwards. nvidia and ATI decide whether or not
it's worth it for them to release binary drivers targeted at any
particular distro release. The Fedora Project, whether in a core release
or rawhide, makes no pretense at "supporting" those drivers.

Exactly.  When we package an X.Org release and include it in the
distribution, we do not intentionally break 3rd party drivers.  Wether
or not 3rd party drivers may or may not work is simply not part of the
decision making process at all.  It doesn't really matter.  The hardware
vendors generally do NOT provide updated drivers for a given X.org
release _until_ there are distributions _shipping_ that release and
thus there is _demand_ for the vendor to support the new X.Org release.

If we were to hold ourselves hostage to the proprietary vendors like
some of the users using proprietary drivers are suggesting, then it
would be 3-6 or more months until the proprietary drivers supported
new X releases.

I fully realize that some users are upset with me and what I have said
so far in this thread.  I can totally live with that.  They may totally
disagree with me on every level about it too.  What they do NOT realize
however, is that doing things _this_ way results in the hardware
vendors releasing updated drivers that work with new X releases _sooner_
rather than later.

In other words, by releasing 7.1 _now_ for FC5, we are doing a
_favour_ to people who use proprietary drivers, because they will
have _working_ drivers _sooner_.  Much sooner.

If I hated proprietary vendors, like some people seem to want to paint
a picture of, then I would be trying to avoid ever releasing an update
for FC5 X.

The bottom line is that some may disagree vehemently with this, but
those very same people are the ones who most directly benefit from
the end results.  Ironic isn't it?



http://www.nvnews.net/vbulletin/showpost.php?p=946216&postcount=4
but this should not stop you from realeasing xorg-7.1
if someone for (whatever reason) don't wont to use it they should still wait until updated drivers are available. but we should atleast inform user that the new X will break their drivers (fedoranews)
but silently break things _is_ wrong


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]