Extras i386 rawhide rebuild in mock status 2007-04-16

Mamoru Tasaka mtasaka at ioa.s.u-tokyo.ac.jp
Tue Apr 17 02:12:31 UTC 2007

Matt Domsch wrote, on 04/17/2007 10:19 AM:
> Extras Rawhide-in-Mock Build Results for i386 Mon Apr 16 08:07:44 CDT 2007
> Total packages: 2944
> Number failed to build: 134
> Number expected to fail due to ExclusiveArch or ExcludeArch: 2
> Leaving:  132
> (there may be some duplicates if rawhide has 2 versions of a package)
> Of those expected to have worked...
> Without a bug filed: 132
> ----------------------------------
> qdbm-1.8.75-1.fc7	mtasaka at ioa.s.u-tokyo.ac.jp

This is strange. root.log
says that although 'ruby' is included as BuildRequires, ruby is not
installed at the mock build time.

Executing /usr/sbin/mock-helper yum --installroot 
/var/lib/mock/fedora-development-i386-core-qdbm-1.8.75-1.fc7.src.rpm/root install 
'zlib-devel' 'ruby-devel' 'bzip2-devel' 'gcc-java' 'libgcj-devel' 
'perl(ExtUtils::MakeMaker)' 'ruby'

  Package                 Arch       Version          Repository        Size
  bzip2-devel             i386       1.0.4-10.fc7     core              283 k
  gcc-java                i386       4.1.2-8          core              2.7 M
  libgcj-devel            i386       4.1.2-8          core              1.5 M
  ruby-devel              i386       1.8.6-2.fc7      core              559 k
  zlib-devel              i386       1.2.3-10.fc7     core               81 k
Installing for dependencies:

And actually I tried mockbuild and it succeeded.
Maybe "yum" you are using is somewhat broken?


More information about the fedora-devel-list mailing list