bcm43xx_mac80211 (was Re: Announcing Fedora 7 Test 4 (6.93))

Martin Sourada martin.sourada at seznam.cz
Fri May 11 22:14:11 UTC 2007

Martin Sourada wrote:
  > Hm... the system-config-network then shows it in the hardware list and
> allows me to create a device. If I run ifup wlan0 however, I get this 
> error:
> Error for wireless request "Set Bit Rate" (8B20) :
>     SET failed on device wlan0 ; Operation not supported.
> And it fails to connect - but that is OK, since I don't have there any 
> wireless network I have access to...
> Maybe I should try eth1, as kudzu find it as eth1? Or is wireless 
> supposed to be handled by NetworkManager completely?
> Thanks,
> Martin

I am still trying the bcm43xx_mac80211 driver. Using the NetworkManager I cannot 
connect to the network I have access to, with ifup wlan0 (with the edited 
modprobe.conf to have alias wlan0 bcm43xx_mac80211 set) same error as in my 
previous message (quoted above) and no luck with connection (and yes, I set the 
wlan0 device settings in network manager correctly). Any ideas? Tomorrow I plan 
to try out the bcm43xx driver to see if thinks go better with it. I'll let you 
know the result.

Well, and one another thing: output of iwconfig:
# iwconfig wlan0
Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     IEEE 802.11g  ESSID:""
           Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
           Retry min limit:7   RTS thr:off   Fragment thr=2346 B
           Encryption key:off
           Link Quality:0  Signal level:0  Noise level:0
           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
           Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Is the warning worth noticing or is it OK? Can it cause some of the problems I have?


More information about the fedora-devel-list mailing list