ipw3945/iwlwifi/iwl3945 users, please test latest davej kernels

Valent Turkovic valent.turkovic at gmail.com
Tue May 15 10:41:41 UTC 2007

On 5/8/07, John W. Linville <linville at redhat.com> wrote:
> If you are a rawhide user/tester and have ipw3945 hardware, please
> try the latest kernels here:
>         http://people.redhat.com/davej/kernels/Fedora/fc7/
> I am having mixed results with the latest iwl3945 updates, but I'm
> not sure if it is this particular laptop having problems or the driver
> in general.
> Please give the latest kernels a try and let me know how it is working
> for you.  Please also let me know what was the last kernel that worked
> any better for ipw3945 hardware than the current ones.
> At this point, I am quite uneasy about this driver.  It seems to work
> fine at times, then crash or simply refuse to associate at others.
> I am considering backing it out to the 0.0.16 tag or possibly even
> removing it (since the driver has _still_ not been posted upstream).
> Thoughts?
> Thanks,
> John

I have 3945 wireless card and I have one bug that looked much more
serious before I looked into it - but for new users it is a really
show-stopper bug.

I have wireless turned off via wireless switch on my laptop. When I
need wireless I turn it on.
On fedora 7 test 4 with all the latest updates (kernel
2.6.21-1.3142.fc7) when I turn wireless on I still get no wireless!

# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

I looked at module list and the module is loaded!

# lsmod |grep iwl
iwl3945               140797  0
mac80211              139133  1 iwl3945

When I remove and reload the module I get my wireless card regisered!

[root at fedora74 ~]# rmmod iwl3945
[root at fedora74 ~]#
[root at fedora74 ~]# lsmod |grep iwl
[root at fedora74 ~]# modprobe iwl3945
[root at fedora74 ~]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

Warning: Driver for device wlan0 has been compiled with version 22
of Wireless Extension, while this program supports up to version 20.
Some things may be broken...

wlan0     IEEE 802.11a  ESSID:""
          Mode:Managed  Frequency:5.17 GHz  Access Point: Not-Associated
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Please fix this nasty bug!

linux, blog, anime, spirituality, windsurf, wireless
registered as user #367004 with the Linux Counter, http://counter.li.org.
ICQ: 2125241
Skype: valent.turkovic

More information about the fedora-devel-list mailing list