trouble using mock on FC6-x86_64 to build an i386 rpm for FC6

Eric Smith eric at
Thu May 31 00:52:56 UTC 2007

I'm trying to package drawtiming to submit for review.

I've got it building properly with mock and passing rpmlint on
FC6 x86-64.  I'd tried building an i386 RPM using the command
  mock --autocache -r fedora-6-i386-core rebuild drawtiming-0.5-3.src.rpm

(I tried that with and without a "--arch=i386" on the command line, as I
wasn't sure if that would be necessary.)

It fails with a message from configure:
  checking for C compiler default output file name... configure: error: C
compiler cannot create executables

The config.log says:
  configure:2093: checking for C compiler default output file name
configure:2096: gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32
-march=i386 -mtune=generic -fasynchronous-unwind-tables   conftest.c
  /usr/bin/ld: crt1.o: No such file: No such file or directory
  collect2: ld returned 1 exit status

I set up mock on an FC6 i386 system, and was able to build it there
without getting that error.  If it builds on that, what's different
that keeps it from building with mock for the i386 on the x86_64
system?  Is there something else I need to do to make this work?


More information about the fedora-devel-list mailing list