[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Pulseaudio problems

> Hi,
> I am trying to adapt myself to pulseaudio (F8 x86_64).
> I had to change /etc/security/console.perms.d/50-default.perms
> so I can use another X screen (:1) without being root, and without using
> pulse.

>> Hmm? I don't really understand what you edited in that file and what
>> you achieved with this?

This is how I send mplayer output to my TV:

/usr/bin/xinit /usr/bin/xterm -ut -e $HOME/bin/$PROG \
$MOVIE -- /usr/bin/X :1 -layout TV &

With F8, I get not sound at all, unless I execute the above command as root.
Then I created an audio group for myself and added to
/etc/security/console.perms.d/50- default.perms:

# roma
<sound>=/dev/dsp* /dev/audio* /dev/midi* \
/dev/mixer* /dev/sequencer* \
/dev/sound/* /dev/beep \
/dev/snd/* /dev/adsp*


# roma
<console> 0660 <sound> 0660 root.audio

This allows me to get sound without being root (even logged in remotely in a console).

>> BTW: It is a feature, not a bug that PA pauses playback when you
>> switch to a different session.

I know that, and a like it very much.

> audacious 1.4: OK with ESD (stutters a lot with its own pulse
> plugin).

>> Have you filed a bug to the audacious people on that? My PA plugin for
>> XMMS works fine. Apparently they broke it when they took it and ported
>> it to Audacious.

Yes. It works for xmms. I tried to contact the audacious team via IRC,
and they said: "roma, I really do not care"

I tried, yesterday, the latest version, 1.4.2, and got the same result.

> vlc: NO plugin available.

>> I'd assume that this one works fine with our plugin for ALSA.

Yes. But it also works fine with ESD.

>> Yes, I will have another look on the whole Xine situation.

xine and gxine do not work with pulse plugin (the connection is lost after a few
seconds), but totem does (it is based on xine, right?). What is the difference?

I use a self compiled version of xine and gxine with all of the codecs enabled, and
I have no problem using them with the ESD plugin. Pulseaudio works just fine this way.

> I also noticed that using
> arecord -D hw:0.0 -d 0 -f S16_LE -c2 -r48000 | aplay -D pulse &
> for capturing from line in.

>> Hmm? what did you notice?

There is a slight hiccup (missing of sound) from time to time.
It is very fast,and it does not seem to be related to the amount of
processing on my computer: Core 2 duo, 2.1GHz, 2GB ram, x86_64, F8

Paulo Roma Cavalcanti
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]