Memory usage - default X install can't use yum with 1GB RAM machine

Paul Wouters paul at
Thu Oct 11 20:39:06 UTC 2007

On Thu, 11 Oct 2007, James Antill wrote:

> > Mem:   1013676k total,   782344k used,   231332k free,     8788k buffers
> > Swap:   522104k total,   452872k used,    69232k free,   164116k cached
>  You have 522MB of Swap, and 450MB is used. Add more swap.

Well, yum forced everything else into swap when it tried to take more memory
then I had.

> You may also
> find that you have a lot of dead memory due to updated files. prelink
> esp. is great for this.
>  I've attached a simple python script I've used, it's not perfect but it
> shows roughly how much dead memory you have and will kind of show where
> it is.

Your script shows:

num             = 20
vsz             = 2,225,954,816
s_size          = 2,225,954,816
s_rss           = 14,172,160
s_shared_clean  = 13,312,000
s_shared_dirty  = 0
s_private_clean = 389,120
s_private_dirty = 471,040
referenced      = 13,869,056

If I read this correctly, that isn't that much memory lost. And most of
that could be, because I'm running rpm -Uhv in the other window now on
those packages yum downloaded and it has installed 612 of the updates now,
causing old libraries are still used but deleted to take up extra RAM.
(eg your script shows me /lib64/,
/lib64/, /usr/lib64/ etc)

Note that yum died on the first package it tried to install, so these
old packages files that are in use but deleted, didn't play a part in the
original (dead) memory usage.


More information about the fedora-devel-list mailing list