[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fluendo codecs in Fedora 8?

On 10/25/07, Peter Robinson <pbrobinson gmail com> wrote:
> > I followed instructions for installing fluendo mega codec pack and
> > copied all files to
> > /usr/lib/gstreamer-0.10/ under Fedora 8 test 3 (with latest updates)
> > but whenever I try to open different video files I still get message
> > from Totem that I need to go to fluendo site and get codecs...
> >
> > I then copied files also to ~/.gstreamer-0.10/plugins directory but
> > that doesn't help either...
> >
> > Any ideas? Should I file a bug? Am I doing something wrong?
> Does gst-inspect report the codecs? what about if you put them in a
> plugins directory in the .gstreamer (I think that's the one - not on
> my linux box atm) in your home dir. This is what I've done and they
> seem to work for me with basic testing.
> Pete

I first tried coping them to /usr/lib/gstreamer-0.10 when that failed
I copied them to $HOME/.gstreamer-0.10/plugins. Now I have them on
both places.

$ gst-inspect-0.10 | grep flu
fluac3dec: audio/ac3: no extensions
fluac3dec:  fluac3dec: AC3 decoder
flumpeg4vdec:  flumpeg4vdec: Fluendo MPEG-4 ASP Video Decoder
flumpeg2vdec:  flumpeg2vdec: Fluendo MPEG-2 Video Decoder
fluwmvdec:  fluwmvdec: Fluendo WMV Decoder
fluisodemux:  fluisodemux: ISODemux Demuxer
flumpegdemux:  flupsdemux: MPEG Program Demuxer
flumpegdemux:  flutsdemux: MPEG Transport stream demuxer
fluasf:  fluasfdemux: Fluendo ASF Demuxer
fluasf:  fluasfcmdparse: Fluendo ASF Command Parser
flumms:  flummssrc: Fluendo MMS source
fluwmadec:  fluwmadec: Fluendo WMA Decoder
flump3dec:  flump3dec: Fluendo MP3 Decoder (IPP build)

I copied fluendo codec files to $HOME/.gstreamer-0.10/plugins in
openSuse 10.3 and it worked with some videos that previously it
didn't. Namely it worked with one mpeg1 file named bespring.mpg the
same file under same player on Fedora 8 test 3 gives this error:

$ totem /data/bedspring.mpg

(totem:3725): GStreamer-WARNING **: Failed to load plugin
/home/fedora8test3/.gstreamer-0.10/plugins/libgstfluac3dec.so: cannot
restore segment prot after reloc: Permission denied

(totem:3725): GStreamer-WARNING **: Failed to load plugin
cannot restore segment prot after reloc: Permission denied
** Message: don't know how to handle video/mpeg, mpegversion=(int)1,
** Message: Missing plugin: gstreamer|0.10|totem|MPEG-1 Video
decoder|decoder-video/mpeg, mpegversion=(int)1,
systemstream=(boolean)false (MPEG-1 Video decoder)
XID: 77594627

Any ideas?

Does this look to you like totem of fluendo bug?

linux, blog, anime, spirituality, windsurf, wireless
registered as user #367004 with the Linux Counter, http://counter.li.org.
ICQ: 2125241, Skype: valent.turkovic

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]