problems writing cd/dvd

Manuel Wolfshant wolfy at
Mon Sep 17 14:34:48 UTC 2007

I've been hit by a problem which I _think_ is due to a bug in growisofs, 
but  I am not sure. Basically, the disks written (either directly with 
growisofs or via k3b) sometimes are OK but most often then not, they are 
not recognized as being ISO9660. For instance:

    [wolfy at wolfy64 ~]$ isoinfo -i /tmp/test.iso -d
    CD-ROM is in ISO 9660 format
    System id: LINUX
    Volume id: test
    Volume set id:
    Publisher id:
    Data preparer id:
    Application id: GENISOIMAGE ISO 9660/HFS FILESYSTEM CREATOR (C) 1993
    E.YOUNGDALE (C) 1997-2006 J.PEARSON/J.SCHILLING (C) 2006-2007 CDRKIT
    Copyright File id:
    Abstract File id:
    Bibliographic File id:
    Volume set size is: 1
    Volume set sequence number is: 1
    Logical block size is: 2048
    Volume size is: 12060
    NO Joliet present
    Rock Ridge signatures version 1 found
    [wolfy at wolfy64 ~]$ growisofs -Z /dev/dvdwriter=/tmp/test.iso
    Executing 'builtin_dd if=/tmp/test.iso of=/dev/dvdwriter obs=32k seek=0'
    /dev/dvdwriter: "Current Write Speed" is 4.1x1352KBps.
              0/24698880 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
              0/24698880 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
              0/24698880 ( 0.0%) @0x, remaining ??:?? RBU 100.0% UBU   0.0%
        1048576/24698880 ( 4.2%) @0.2x, remaining 5:38 RBU 100.0% UBU   3.1%
       17825792/24698880 (72.2%) @3.6x, remaining 0:07 RBU  41.0% UBU  99.8%
    builtin_dd: 12064*2KB out @ average 0.9x1352KBps
    /dev/dvdwriter: flushing cache
    /dev/dvdwriter: stopping de-icing
    /dev/dvdwriter: writing lead-out
    /dev/dvdwriter: reloading tray
    [wolfy at wolfy64 ~]$ isoinfo dev=/dev/dvdwriter  -debug
    CD-ROM is NOT in ISO 9660 format

    The problem can be reduced sometimes to the following sequence:

    [wolfy at wolfy64 tmp]$     for i in `seq 1 5`; do growisofs -Z
    /dev/dvdwriter=/home/wolfy/cd_space/ghost.iso ; isoinfo
    dev=/dev/dvdwriter  -debug;done

--> exhibited no error. Trying again, 1 min later with absolutely no 
change in the system:

    [wolfy at wolfy64 tmp]$ growisofs -Z
    WARNING: /dev/dvdwriter already carries isofs!
    About to execute 'builtin_dd if=/home/wolfy/cd_space/ghost.iso
    of=/dev/dvdwriter obs=32k seek=0'
    /dev/dvdwriter: "Current Write Speed" is 4.1x1352KBps.
    builtin_dd: 1344*2KB out @ average 1.0x1352KBps
    /dev/dvdwriter: flushing cache
    /dev/dvdwriter: stopping de-icing
    /dev/dvdwriter: writing lead-out
    [wolfy at wolfy64 tmp]$ sudo mount /dev/dvdwriter /mnt/dvd
    mount: you must specify the filesystem type

    I've tried (but failed) to finalize the disk manually, using:

    [wolfy at wolfy64 tmp]$   growisofs -M /dev/dvdwriter=/dev/zero
    :-( /dev/dvdwriter doesn't look like isofs...


Now, I do admit that I might be plain dumb, but I've tested dozens of 
times and
- about 15 of the DVDs written for the Freemedia project during the last 
month (that is, roughly half of them) are non functional. All of them 
have been created using the option "write dvd to disk" from k3b
- other .iso images (see above) are sometimes written OK, sometimes 
(most of the times) not
- disks created using genisoimage with the option "-udf" (in whatever 
combination) seem to fail always
- the problem was first spotted while using an ASUS 804P (ATA) which is 
now used by a colleague without problems; meanwhile I  have replaced it 
with a SATA unit, DRW-1814BLT.
- I have replaced the power supply
- I have used several types of media(DVD-R, DVD+R, lately DVD+RW, from 
different manufacturer[s] lots) but I have found no correlation
- I have tried to disable udev (udevcontrol stop_exec_queue)/dbus 
(service messagebus stop) but to no avail. For a period of time I had 
the impression that writing a dis and allowing the system to automount 
it would lead to defective subsequent written disks. However the problem 
appears even if I explicitely umount the first disk , or if I do not 
mount it at all.

    I emphasize that I have absolutely no other problems with the system

    It looks to me like a bug in finalizing the disks, but I do not know 
how to test (no other machine with DVD-ROM and anything else but linux 
around). Any ideas, before filing a bug?

More information about the fedora-devel-list mailing list