diff between Fedora + EPEL builds (python)

Toshio Kuratomi a.badger at gmail.com
Sat Sep 22 02:47:28 UTC 2007

Hash: SHA1

Neal Becker wrote:
> Jeremy Katz wrote:
>> On Thu, 2007-09-20 at 20:09 -0400, Neal Becker wrote:
>>> I'm having trouble updating mecurial.  I pushed an update to F-7 and
>>> devel.
>>> It doesn't build on EL-4 though.  The problem seems to be, that python
>>> setup.py build/install creates .pyc/.pyo on  F-7 and devel, but not on
>>> EL-4.  Then, I get 'file not found by glob' for the missing files.  I
>>> also
>>> tried %ghost on them, but EL-4 still complains they're missing.  Anyone
>>> know what this is about and maybe how to fix it?  I'd like to make
>>> mercurial for EL-4.
>> RHEL4 doesn't do automatic byte-compiling of .py files.  You can change
>> the invocation of the setup install to be -O2 instead of -O1 to get
>> the .pyo files generated as well
don't use -O2.  -O1 is sufficient to generate optimized files.  -O2
compiles the extensions without docstrings.  This can cause runtime
problems if the code depends on the existence of docstrings.

> Thanks - but still fails.  Acutally, it doesn't generate .pyc or .pyo. 
> Still not sure how to fix this.
> See:
> http://buildsys.fedoraproject.org/logs/fedora-4-epel/36416-mercurial-0.9.4-7.el4/i386/build.log
- From the build log it looks like there's a couple things going on:

1) Unrelated, you should specify CFLAGS to the build so that you pick up
FORTIFY_SOURCE and other Fedora standard cflags::
  CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build

2) The main portion of the package appears to be installed with byte
compiled  files just fine.  It's only files in
/usr/share/mercurial/contrib/ that seem to have the problem. I highly
suspect that you should be moving that whole directory into %doc and
globbing the whole thing.

- -Toshio
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the fedora-devel-list mailing list