NetworkManager-0.7 can't make new wireless connection

Matthew Saltzman mjs at CLEMSON.EDU
Fri Sep 28 22:28:35 UTC 2007

On Fri, 2007-09-28 at 14:41 -0700, Tom London wrote:
> On 9/28/07, Matthew Saltzman <mjs at> wrote:
> >
> > I guess NetworkManager will work with unencrypted WAPs.  It may work
> > with WEP WAPs.  system-config-network works fine with WEP, but doesn't
> > support WPA.  Have not tried wpa_supplicant.  Does anyone know of a
> > step-by-step, quick-start HOWTO for wpa_supplicant?
> >
> I have it running with 'visible SSID' WPA.  Requires 'converting' your
> passphrase into the derived hex key:
> 1. run '/usr/sbin/wpa_passphrase <SSID> <PASSPHRASE>', substituting
> your WPA ssid/passphrase.
> 2. select and copy the part of the output showing the hex key.
> 3. When you select the WPA network in NM, paste the hex key.  The
> enter button should be enabled.
> 4. It should then ask about your keyring passphrase. If you enter it,
> you won't have to do the above again....;)
> Example:
> [root at localhost ~]# /usr/sbin/wpa_passphrase MY-SSID myPassPhrase
> network={
>         ssid="MY-SSID"
>         #psk="myPassPhrase"
>         psk=448ebab0a19b567dfe4089e5e92900932e4f1a7093f7a9fbf793ed43cbc95f57
> }
> [root at localhost ~]#
> copy/paste text after 'psk=', etc.
> For 'wpa_supplicant', I found the man pages for wpa_supplicant.conf
> and wpa_supplicant useful.

Got connected!  Yay...

Tried to create a VPNC connection, but the wizard just exits after I
select the vpnc connection type (which is the only type offered at this
point).  Is that supposed to work yet?


> tom
                Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu

More information about the fedora-devel-list mailing list