Network Manager Summary

Jeff Spaleta jspaleta at
Thu Apr 3 23:36:42 UTC 2008

On Thu, Apr 3, 2008 at 3:02 PM, Mike Chambers <mike at> wrote:
>  I also called up that UI and I had *NO* listings in there, yet I have
>  eth0 and worked fine with the "network" service.  I think maybe there
>  was dns issue when trying to use network manager,and either/neither eth0
>  was discovered, or dns didn't work?  But *all* of the buttons were
>  grayed out for me on that UI.

If you have used the system-config-network dialog to manage devices
you'll need to use the dialog again, edit the device and make sure
NetworkManager controlled is enabled.

It appears that the system-config-network gui defaults to turning off
NetworkManager control by setting the appropriate variable in the
ifcfg file it creates for the device... for any dievice you configure
through the system-config-network dialog.  You have to go back into
the gui and explicitly ask for NM control for the device for NM to
list it.

So once you use the legacy dialog for anything.. you pretty much could
be telling NM to no longer show the device.  I ran into this on F8


More information about the fedora-devel-list mailing list