[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

preupgrade - what would it take to provide packages for unsupported fedora releases ?



I thought I might try preupgrade out on Fedora Core 3:
=====
# rpm -Uvh preupgrade-0.9.2-1.fc8.noarch.rpm
error: Failed dependencies:
        python(abi) = 2.5 is needed by preupgrade-0.9.2-1.fc8.noarch
        yum >= 3.2.8 is needed by preupgrade-0.9.2-1.fc8.noarch
        yum-metadata-parser is needed by preupgrade-0.9.2-1.fc8.noarch

[root f3 davidt]# rpm -Uvh preupgrade-0.9.2-1.fc8.noarch.rpm  --nodeps
Preparing...        ########################################### [100%]
   1:preupgrade     ########################################### [100%]

[root f3 davidt]# preupgrade
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 23, in ?
    import preupgrade
ImportError: No module named preupgrade

[root f3 davidt]# rpm -q python yum yum-metadata-parser
python-2.3.4-11
yum-2.1.11-3
package yum-metadata-parser is not installed
=====
Is there actually python 2.5 constructs used ?
Could it be built for an earlier release like fc3 ?

This would have to circumvent the maintained distributions policy, but
for good reason; weaning our upgrade adverse users off the no longer
maintained old F2,3,4,5,6 releases.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]