[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

My (unpleasant) fedora 10 installation experience

Hi all,

Today the file system on my wife's laptop got corrupted (that's another sad
fedora, kerneloops and tuxonice story) and I decided to reinstall everything
from scratch using Fedora 10 installation DVD. The laptop previously had Fedora
9 installed, so my plan was to reinstall the system and then restore the /home
partition with fsck & co.

The installation process from the DVD went quite smoothly, but when I got to the
first boot there were some surprises. Since I was going to recover /home later,
I was not planning to create any users at the first boot, but skipping the
"Create user" screen required to press the "Use network login..." button and
cancel the dialog, otherwise the firstboot continued to complain that I
definitely need to create a user.

This laptop uses wireless to connect to the internet, and guess what? Is is NOT
yet configured when you are running the firstboot. On the Date & Time screen I
selected "Enable network time protocol", pressed forward, and then hit Cancel on
the "Contacting NTP..." dialog (I supposed that I don't want to wait for the
network timeout) and... Firstboot crashed leaving me with an empty screen with a
mouse cursor on it. Ctrl-Alt-F1/F2/etc. brought me to another empty screen,
without a mouse this time. Fortunately Ctrl-Alt-Del from that mouseless screen
worked fine.

Next boot showed firstboot again allowing to test these bugs and finally get
through them to discover another surprise.

I've selected "Russian" keyboard during the installation process. Usually this
assumed that there are two keyboard layouts (English and Russian) and you can
switch between them with a hotkey. But not in the default state of the GDM after
the first boot. The only option I had was Russian input! I tried all common
layout switch shortcuts but have not managed to find one to switch the layout to
english, but I had to type something in english since I have not created any
users and my root user had both english login name and password. So I had to go
to the menus, search for USA keyboard layout and only after this had a chance to
try login to the system. It really seems to me that these layout defaults are
insane. Is it that common to have non-english login names and passwords, really?

Anyway, I failed to login interactively to X as root ("Cannot authenticate
user") and after that even selecting Keyboard: USA did not bring english input
to the gdm! I tried to switch several times, nothing happened. Adding a second
USA layout (USA international this time) partially solved the problem with
switching input language, but I still was not able to login as root to a
graphical terminal to recover the system. Of course some searching in google
delivered the answer that I have to modify the gdm PAM settings, but that only
brought me to a discovery that gdm forgets the input language and layout
settings after asking for the user name! So the complete "root login" procedure
looks like this:
1. Press "other user..." [Why should I do this if there are no users in the
system except root?]
2. Switch layout to USA. [First switch is broken, so]
3. Switch layout to USA (intl). [Aha, english letters finally]
4. Enter user name
5. Switch layout to USA. [Don't forget: the first switch is broken]
6. Switch layout to USA (intl).
7. Enter the root password.

Phew, That was easy!

Never ever before a fresh Fedora installation was that hostile towards system
recovery... Especially to a non-US user. That is sad.

With best regards,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]