[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Getting started with Rawhide

I've had some bug reports recently against a couple of my packages.
These bugs apparently manifest only in Rawhide.  So now I am trying to
get a virtual machine setup with Rawhide installed so I can debug
these problems.  I'd like to keep it around long-term, too, so I can
help debug things as they come up.

However, I've had a few ... issues ... getting started with Rawhide.
Is there a "Getting started with Rawhide" guide anywhere?

First, I couldn't get the Rawhide CD image to finish an installation.
Weirdly, it failed in different ways every time I tried to use it.  So
I tried to use the F10 -> Rawhide update method with yum documented
here [1].  I installed from my F10 DVD, then *without updating F10*,
changed repositories and did an update from the Rawhide repository.

It appears that glibc in Rawhide (2.8.90) is older than the glibc in
the initial F10 release (2.9).  Am I seeing that correctly?  If so,
should I downgrade, or wait for Rawhide to catch up?

Can anybody tell me how to get a screen resolution higher than 800x600
in the virtual machine?

Incidentally, the yum upgrade spit out somewhere around a million [2]
warnings that /usr/lib64/libxcb-xlib.so.0 is not a symbolic link,
apparently every time that ldconfig ran.  Since "rpm -V libxcb"
produces no output, this appears to be intentional.  F10 gets this
right (/usr/lib64/libxcb-xlib.so.0 is a symbolic link to

If I can get the kernel to stay up long enough to do anything, I'll
start trying things out and flinging bug reports where appropriate.
So far, it hasn't stayed up for very long.  Good thing I've still got
the F10 kernel around...

[1] http://fedoraproject.org/wiki/Releases/Rawhide
[2] I may be exaggerating slightly.
Jerry James

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]