[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pulseaudio causing crashing of applications

Right, I'm having fun with PA not working and having to log out and in
to get it up and running again.  For reasons I can't explain, PA just
stops responding.  This can be seen in a number of ways:

The sound on VMWare Player complains that /dev/snd (I think) isn't

Rhythmbox will seem to work fine, but any attempt to play a file results
in no sound and the time-line indicator doesn't move from the start (or
actually, it starts to move and then goes back to the start).

Sounds from various applications don't play.

> This sounds as if some other process blocked the audio device when
> switching back the session so that PA was unable to reopen the device
> and thus playback stays suspended.
> Could you please check this, by running "pactl" in a terminal when
> this happens again, and then type "list-sinks"? If your sound card
> sink remains in SUSPENDED state, than this is most likely the issue.
> Or, you might have hit the well-known issue HAL where it fails to
> restore ACLs sometimes and thus PA is not able to reopen the device
> properly. Check getfacl /dev/snd/*

So, I'm intersted in this so I can try to debug this and provide useful
information for resolving this issue.

I tried running pactl, but get this:

[rodd localhost ~]$ pactl 
No valid command specified.

I then tried

[rodd localhost ~]$ pactl list-sinks
No valid command specified.

Finally I did a check of man pactl and then tried 'pactl list' but this
gives a huge output, only some of which is 'sinks'.

How would I tell what state my sound card is in (currently it's working,
but I wanted to try all this while everything worked so I could see
what's changed.)


"It's a fine line between denial and faith.
 It's much better on my side"

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]