[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pulseaudio causing crashing of applications

Rodd Clarkson wrote:
This sounds as if some other process blocked the audio device when
switching back the session so that PA was unable to reopen the device
and thus playback stays suspended.

Could you please check this, by running "pactl" in a terminal when
this happens again, and then type "list-sinks"? If your sound card
sink remains in SUSPENDED state, than this is most likely the issue.

Or, you might have hit the well-known issue HAL where it fails to
restore ACLs sometimes and thus PA is not able to reopen the device
properly. Check getfacl /dev/snd/*

So, I'm intersted in this so I can try to debug this and provide useful
information for resolving this issue.

I tried running pactl, but get this:

[rodd localhost ~]$ pactl No valid command specified.

I then tried

[rodd localhost ~]$ pactl list-sinks
No valid command specified.

Finally I did a check of man pactl and then tried 'pactl list' but this
gives a huge output, only some of which is 'sinks'.

How would I tell what state my sound card is in (currently it's working,
but I wanted to try all this while everything worked so I could see
what's changed.)

Yeah pactl list is correct, and I think the state is included in the FLAGS, so one of the flags included on the line for that on each sink would be SUSPENDED, if its not there its not suspended. I have not yet seen it marked suspended when this bug occurs (and rhythmbox freezes).

Andrew Farris <lordmorgul gmail com> www.lordmorgul.net
 gpg 0xC99B1DF3 fingerprint CDEC 6FAD BA27 40DF 707E A2E0 F0F6 E622 C99B 1DF3
No one now has, and no one will ever again get, the big picture. - Daniel Geer
----                                                                       ----

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]