[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Boot fails with "No Setup Signature" after update following YumUpdateFaq

The Problem:

I recently upgraded a system from Fedora Core 6 to Fedora 8 using the YumUpdateFaq as a guide. When I tried to reboot the system with kernel the system hung in the boot process with the message "No Setup Signature". However I could boot the system with kernel

The investigation:

I tried reinstalling the kernel without success. I found on a mailing list a case where this problem was fixed by running grub-install. When I did this it also resolved my problem. I also remembered there has a note in the YumUpdateFaq about possibly needing to do this with a TODO note by Mads Kiilerich asking when this was required.

I contacted Mads, who acted as a sounding board as I investigated why I needed to run grub-install. I determined by running "less -f /boot/grub/stage2" on a backup taken before I ran grub-install that the version of the GRUB files in /boot/grub was 0.92 whereas the current GRUB version, since Fedora Core 5, is 0.97.

I determined that when YUM/RPM upgrades or installs GRUB, the files in /boot/grub do not get updated. This only happens when grub-install is run. When the system is upgraded from CD/DVD, Anaconda runs grub-install, although this can be bypassed. I had updated the system several times up to Fedora Core 6 using CD/DVD but skipped the GRUB update part of the install.

To run grub-install in Fedora 8 (or 7) it is necessary that /boot/grub/device.map has the new drive device naming. This file, which is created by Anaconda, needs to be modified from "(hd0) /dev/hda" to "(hd0) /dev/sda" if it was created in Fedora core 6 or earlier.

The Solution:

Mads and I came up with the following changes to the YumUpdateFaq.

1> In section 4 "Do the upgrade", the following was added

Before booting you should usually install the bootloader from your new grub by running

    * grub-install BOOTDEVICE

    - where BOOTDEVICE usually is /dev/sda

2> To the end of the first paragraph under "Fedora Core 6->Fedora 7" discussing the IDE drive device name change, the following was added.

In /boot/grub/device.map change /dev/hd.. to /dev/sd.. before running grub-install - and don't change (hd0). Changing /boot/grub/grub.conf may also be required.

Roy Rankin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]