[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora rawhide rebuild in mock status 2008-08-28

On Tuesday 02 September 2008, Jerry James wrote:
> 2008/9/2 darrell pfeifer <darrellpf gmail com>:
> > I was getting that error in rawhide for the last several weeks when
> > running the (sun) java command at the command line, on a 32 bit machine.
> >
> > Using the full path to the binary worked.
> >
> > With yesterday's rawhide update the problem has gone away.
> Thanks, Darrell.  Then I'll do nothing and see if those packages
> disappear from Matt's report.

Some possibly related things Java packagers should be aware of, I ran into 
several issues earlier this week when rebuilding javasqlite in devel:

javac->ecj symlinking may cause use of class libraries from wrong java: 
Workaround: set up $PATH so that the pathless "java" invoked by /usr/bin/ecj 
corresponds to the "javac" you intended to run.  I suppose generally this is 
a problem currently only with builds done with java-1.5.0-gcj's javac (which 
may end up using java-1.6.0-openjdk's class libs), and most packages probably 
don't have any problems with this.

yum does something weird with "Requires: java-devel" on x86_64, resulting in 
the above issue being triggered pretty easily as well as possibly some other 
nasty arch mismatch issues: https://bugzilla.redhat.com/460783
Workaround: not sure; for javasqlite it went away when I added some a couple 
of java-devel build dependencies with explicit versions (not because of 
this - it was needed anyway for what I wanted to accomplish).

I don't think these are actually anything new in Rawhide only, I see them in 
F-9 as well.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]