[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mono breaks with dynamic linking on ppc? [was Re: Mono-2.4 and ppc in rawhide]



Jerry James wrote:
> On Mon, Apr 13, 2009 at 8:46 PM, Toshio Kuratomi <a badger gmail com> wrote:
>> So mono builds itself and then uses the resulting binary during the
>> build process.  If we link that binary dynamically against libmono.so,
>> at least some subsequent commands break on ppc.  If we link that binary
>> statically against libmono.so (but dynamically against everything else)
>> then subsequent commands work fine and we get mono packages built.  Does
>> this sound like a bug in gcc or the dynamic linker?  Does this remind
>> anyone of some other bug they've encountered in the past?
>>
>> -Toshio
> 
> Wild shot in the dark: is -fPIC supplied for every single source file
> and also for the link command to create libmono.so?
> 
I don't know for sure but I'd expect x86_64 to break as well if that
wasn't happening.

> When subsequent commands "break", how exactly are they breaking?
> 
In the mono build, mcs.exe is used to build some C# files and that
overflows the stack:
Stack overflow in unmanaged: IP: 0xf8b4b54, fault addr: 0xff18bda0
Stack overflow in unmanaged: IP: 0xf8b4b54, fault addr: 0xff18abd0

(More details are in the build.log's linked from this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=494026
)

> Is this still a koji-only problem, or can it be reproduced on
> somebody's personal machine now?

Nope.  It can be reproduced on personal machines as well.

-Toshio

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]