[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Use bash patchlevel as part of RPM version?



On Tue, Apr 21, 2009 at 09:02:09AM +0200, Roman Rakus wrote:
> Hi,
> There is a bug (#496780) requesting to use patchlevel of bash as part of  
> RPM version. So today bash-4.0-6.fc11.i586 would be  
> bash-4.0.16-6.fc11.i586. What do you think about it? Could it break  
> anything?
> RR
>

Since bash doesn't have any fancy provides try something like

for package in `repoquery --whatrequires bash`; do echo $package; repoquery -R $package|grep bash; done

to check what dependencies are pointing to bash's version. I think it
looks quite safe, but OTOH we're in a freeze with bash being an
important package, so it's better to change it for >= F12 or at the
very least as an update to 4.0.17 later in F11's maintenance timeline.
-- 
Axel.Thimm at ATrpms.net

Attachment: pgpmBvl9Fpt6A.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]